読者です 読者をやめる 読者になる 読者になる

【EIGRP】経路集約

EIGRPの経路集約のポイント



・EIGRPでは自動集約をデフォルトでサポート(クラスフルネットワークの境界でのみ集約される)

・任意のインタフェースで手動集約が可能

・集約された場合(自動/手動問わず)はルーティングループ防止のためNULL0インターフェースを自動で生成する。

・集約後のメトリックは集約前の経路の最小値

・自動集約を無効にする場合は「no auto-summary」コマンドを使用する

・自動的に作成されたNULL0集約経路宛のAD値は5



手動集約の設定コマンド

(config-if)#ip summary-address eigrp {AS番号} {アドレス} {サブネットマスク} [AD値]

【EIGRP】スタブ

EIGRPスタブの設定について。

ルートの受信はするが送信の制限をかけられる。

EIGRPのスタブ設定コマンド

Router(config-router)#eigrp stub [ receive-only | connected | static | summary ]

receive-only・・・ルート情報を一切送信しない(受信はする)
connected・・・直接接続されたルートのみ送信
static・・・スタティックルートのみ送信
summary・・・サマリールートのみ送信
※オプションを指定しない場合はconnectedとsummaryをアドバタイズします

【EIGRP】デフォルトルート

EIGRPでデフォルトルートをアドバタイズする方法には3種類あります。



■パターン1. スタティックデフォルトルートをアドバタイズさせる
(config)#ip route 0.0.0.0 0.0.0.0 { 宛先IP | インターフェース } ・・・スタティックデフォルトルートの作成
(config)#router eigrp { AS番号 }
(config-router)#network 0.0.0.0 ・・・全てのインターフェースでEIGRPを動作させる(デフォルトルートがある場合は、ネイバーにデフォルトルートをアドバタイズする)

■パターン2. スタティックデフォルトルートを再配送させる
(config)#ip route 0.0.0.0 0.0.0.0 { 宛先IP | インターフェース } ・・・スタティックデフォルトルートの作成
(config)#router eigrp { AS番号 }
(config-router)#redistribute static ・・・スタティックルートを再配送する

■パターン3. アドバタイズするルートにデフォルトルートのフラグを付ける
(config)#ip default-network { ネットワークアドレス }
ここで指定するネットワークアドレスはクラスフルのアドレスに限定されます。

【EIGRP】用語の定義

FD(Feasible Distance)

自ルータから宛先ネットワークまでの合計メトリック



AD(Advertised Distance)

ネイバールータから宛先ネットワークまでの合計メトリック(ネイバーが教えてくれたメトリック)



サクセサ

通常使用するメインルート。

複数の経路がある場合FDの一番低い経路がサクセサとなる。



フィージブルサクセサ

サクセサのバックアップルート。サクセサがダウンした時に代わりに使用する。

このために高速なコンバージェンスを実現している。

不等コストロードバランシングではルートとして使用する場合もある。

サクセサのFDよりも低いADを持った経路がフィージブルサクセサになれる。



ラストリゾートゲートウェイ

デフォルト・ルートは,ルーティング・テーブル中にあて先IPアドレスに該当するエントリがない場合に使用する経路を指す。

 つまり,「どこへ送っていいかわからないパケットの送り先」がデフォルト・ルートである。そのため,デフォルト・ルートのエントリに設定されたネクスト・ホップは「ラスト・リゾート・ゲートウエイ(最後の手段のゲートウエイ)」と呼ばれる。



Passive状態

ネットワークが安定した状態で、ルーティングが可能。



Active状態

ネットワークに対するルートを計算している状態。ルーティングループを防ぐためルーティングしない。

フィージブルサクセサがない状態でサクセサがダウンすると、ネイバーに問い合わせ(Queryを送信)し、ネイバーから応答(Reply)があるまでActive状態になる。



不等コストロードバランシング

経路が複数ある場合かつ、メトリックが等しくない場合でもそれらの経路を使用してルーティングし、負荷を分散させる。



最大パス数

EIGRPでは同じメトリックであればデフォルトで4経路をルーティングテーブルに格納できる。

最大を16経路まで変更可能。



K値

K 値は、EIGRP がルートの計算で使用するメトリック。

デフォルトは「K1=1, K2=0, K3=1, K4=0, K5=0」

K2,K4,K5のK値(0)を変更した場合は、メトリック計算にインタフェースの負荷と信頼性が含められることになります。これらは時間とともに変化し、変化のたびにトポロジデータをフラッディングしてしまうことになります。そのため、 K2,K4,K5のK値は 0 のままにしておくことが推奨されています。



AD(Administrative Distance)

ベストパスの判断基準。内部EIGRPのAD値は 90、外部EIGRPのAD値は 170



EIGRPパケットの最大占有割合

EIGRPパケットがネットワーク上で占める割合(最大値)。変更可能。

デフォルトは50%まで



SIA(Stuck In Active)

ルータがActiveの状態のままになってしまうこと。

代替経路を探すためにクエリを送ったものの応答が返ってこない場合に起こる。

対策としてアクティブタイマーがある。一定時間後(デフォルト3分)にクエリを返さなかったネイバーをダウンとしてPassive状態に戻る。

スタブルータにはクエリを送らないため、スタブの設定でクエリの到達範囲を制限できる。

【Route Map】設定

特定の条件に一致(match)した場合に動作を指定(set)する仕組みです。



設定方法と例

設定方法は以下のとおりです。

Map名と一致した場合にpermitするのかdenyするのかの指定とシーケンス番号を設定
(config)#route-map {マップ名} [permit | deny] [シーケンス番号]
例)#route-map TEST_MAP permit 10

一致の条件を指定する
(config-router-map)#match {条件}
例)#match ip address 1

一致した場合の動作を指定する
(config-router-map)#set {動作}
例)#set ip precedence critical
例の内容ではTEST_MAPでACL 1に一致した場合QoSのCriticalがセットされます。



使用される場所としては、再配送、PBR、BGP、NATが挙げられます。

再配送で使用する場合の例として下記のように記述します。

この場合はOSPFにRIPのルートを再配送するケース

(config)#router ospf 1

(config-router)#redistribute rip route-map TEST_MAP

【ルーティング機能】Passive interface

パッシブインターフェースを使用することでルーティングのアップデートを抑制して無駄な帯域消費を抑制できます。



EIGRP・OSPFとRIPでパッシブインターフェースの挙動が異なります。

EIGRP・OSPFはHelloパケットを送信しないため隣接関係も構築しません。そのためルーティングアップデートも送受信しません。

RIPはルーティングアップデートを送信しませんが受信します。



設定はルーティングのコンフィグレーションモードにて行います。

(config-router)#passive-interface {default | インターフェース}

defaultオプションを設定すると全てパッシブインタフェースとなります。

インタフェースを指定すると指定したインターフェースのみパッシブインターフェースになります。

そのため、設定方法は下記の2通りあります。

全てパッシブインターフェースにして必要なインターフェースをno passive-interfaceコマンドによってパッシブ状態を無効化する方法
アップデートが不要なインタフェースのみパッシブ状態にする方法

【再配送】シードメトリック

異なるルーティングのプロセス間でルート情報を通知するには再配送(redistribute)が必要です。

ただし、ルーティングプロトコルごとにメトリックの考え方は異なるので、メトリックには互換性がありません。そのため、手動でメトリックを設定してあげる必要があります。この再配送の際に与えるメトリックをシードメトリックと呼びます。

手動で設定しなかった場合はデフォルトシードメトリックが使用されます。

プロトコルごとにデフォルトシードメトリックは異なり、下記のようになります。

再配送先のプロトコル シードメトリック
RIP 無限大
IGRP/EIGRP 無限大
OSPF
20、BGPからは1

BGP
IGPのメトリックをMEDにする

RIPとIGRP/EIGRPのデフォルトシードメトリックは無限大です。

このため、適切に手動設定しなければ、到達不能なルートとして扱われるため注意が必要です。